Issue with multiple products
Incident Report for Tink
Postmortem

Introduction

On January 23rd, between 11:05 and 12:25 CET, the Tink platform experienced an outage linked to issues reported on December 19th.

Root Cause Analysis

At 10:29 CET, Tink proceeded with a planned maintenance operation to strengthen the reliability of its distributed database infrastructure. Operations were successfully executed on multiple nodes but failed on one node, which entered into an error state directly impacting the overall database availability.

Remediation

At 12.20 CET the faulty node was temporarily excluded from the database cluster, and impacted products became immediately available again. The faulty database node was later on permanently removed in a controlled manner during a planned maintenance window.

Follow-up actions

In addition to the preventive actions identified earlier in December, Tink will ensure that such operations shall be conducted under planned maintenance windows to minimise customer impact.

Posted Jan 26, 2023 - 09:21 CET

Resolved
We have restored access to all products & services and are closing this incident. This outage was linked to the completion of repairing activities related to the issues experienced on Dec 19th, and we apologise for the inconvenience.
Posted Jan 23, 2023 - 13:58 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 23, 2023 - 13:11 CET
Monitoring
Service is currently recovering and we are actively monitoring the situation.
Posted Jan 23, 2023 - 12:35 CET
Identified
The issue has been identified and we are currently working on a solution.
Posted Jan 23, 2023 - 12:05 CET
Investigating
We are currently investigating an issue with Account Information Services (AIS) and Payment Initiation Services (PIS).
Posted Jan 23, 2023 - 11:17 CET
This incident affected: Payment Initiation, Account Check, Transactions, Income Check, Risk Insights, and Expense Check.