Issue affecting all services
Incident Report for Tink
Postmortem

Introduction

On June 29th, 2022, Tink experienced degraded performance on all our products between 15:09 to 15:36. During that period, Amazon Web Services (AWS) had an ongoing incident with regards to their EBS service affecting us in such a way as us not being able to create new instances of services in a timely manner.

We know how important it is to our customers that we provide a highly available and reliable service and we sincerely apologize for the disturbances this incident caused.

Root Cause Analysis

During the AWS incident, one of our business critical components, the eIDAS proxy service, needed to re-create a number of the running instances but, because of the AWS incident, was unable to do so. Hence the performance of that service degraded quickly. 

Remediation

Replacing the underlying pods and creating new instances of the services solved the problem and the system recovered at 15:36.

Follow-up actions

As a consequence of this incident we will focus on the following actions to prevent similar scenarios from occurring again: 

  • Improved visibility of ongoing AWS incidents in order to prevent issues on our side and quicker remediation.
Posted Jul 06, 2022 - 17:08 CEST

Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 15:42 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2022 - 15:40 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 29, 2022 - 15:31 CEST
Investigating
We are currently investigating an issue that is affecting all Tink services
Posted Jun 29, 2022 - 15:24 CEST
This incident affected: Payments, Account Check, Transactions, Business Account Check, Business Transactions, Income Check, Risk Insights, Money Manager, and Business Manager.