Issue with Transactions and Payment Initiation services
Incident Report for Tink
Resolved
Degraded performance in Transactions and Payment Initiation services from 15:30 to 15:45, services are back to normal.
Posted Jun 30, 2022 - 15:30 CEST